Willow Springs, Oct 5-6 2013

Prepping and driving your Midlana at an autocross or trackday event.
jaxmadine
Posts: 44
Joined: 02 Jul 2013, 04:51
Anti-spam question: 4
Are you a spammer: No

Re: Willow Springs, Oct 5-6 2013

Postby jaxmadine » 08 Oct 2013, 15:12

Pump looks like all the other dead warlbros ive seen. Tis a shame. 132 is cookin tho!

Midlana1
Site Admin
Posts: 2756
Joined: 19 Dec 2008, 16:44
Anti-spam question: 4
Are you a spammer: No
Location: Southern California

Re: Willow Springs, Oct 5-6 2013

Postby Midlana1 » 08 Oct 2013, 15:28

When you say they die, how so? Do they continue to run but just don't pump fuel? Or, do they just stop spinning?

AndreasMergner
Posts: 19
Joined: 05 Sep 2013, 12:28
Anti-spam question: 4
Are you a spammer: No
Location: Albany, NY

Re: Willow Springs, Oct 5-6 2013

Postby AndreasMergner » 08 Oct 2013, 16:48

Wow, that is exciting stuff, Kurt! Too bad about the fuel pump, but still a really, really encouraging experience. I finished the Kimini book a couple days ago. I'm looking forward to the Midlana book now....and hearing about the next track day.

Midlana1
Site Admin
Posts: 2756
Joined: 19 Dec 2008, 16:44
Anti-spam question: 4
Are you a spammer: No
Location: Southern California

Re: Willow Springs, Oct 5-6 2013

Postby Midlana1 » 08 Oct 2013, 17:52

After disassembling the Walbro pump and finding it in perfect condition (apparently) it's got me wondering if the problem is perhaps a failed fuel pressure regulator or a plugged fuel line. Will find out soon.

Midlana1
Site Admin
Posts: 2756
Joined: 19 Dec 2008, 16:44
Anti-spam question: 4
Are you a spammer: No
Location: Southern California

Re: Willow Springs, Oct 5-6 2013

Postby Midlana1 » 08 Oct 2013, 17:54

The next track event may be in about four weeks, but will depend upon the fuel system fix not showing any other nasty surprises.

jaxmadine
Posts: 44
Joined: 02 Jul 2013, 04:51
Anti-spam question: 4
Are you a spammer: No

Re: Willow Springs, Oct 5-6 2013

Postby jaxmadine » 08 Oct 2013, 20:24

They usually just stop spinning. Bushing goes out and they hang up on the end and stop spinning. Try running it on a bench?

jaxmadine
Posts: 44
Joined: 02 Jul 2013, 04:51
Anti-spam question: 4
Are you a spammer: No

Re: Willow Springs, Oct 5-6 2013

Postby jaxmadine » 13 Oct 2013, 15:39

Glad it was just something silly. Didnt know u had an inline filter, or inline pump for that matter. Lol.
btw. That motor mount bolt seems a little short.

Midlana1
Site Admin
Posts: 2756
Joined: 19 Dec 2008, 16:44
Anti-spam question: 4
Are you a spammer: No
Location: Southern California

Re: Willow Springs, Oct 5-6 2013

Postby Midlana1 » 14 Oct 2013, 07:39

Yeah for those who don't visit my website, the entire problem was due to installing the 10-micron fuel filter backwards! Over time, the filter element inside eventually got pushed off its mount, hit the other end of the housing, and fuel pressure pressed the end cap into the outlet port - instant zero flow. The tip-off was that the filter element end cap was domed.

WickedOne
Posts: 129
Joined: 01 Jan 2009, 08:51

Re: Willow Springs, Oct 5-6 2013

Postby WickedOne » 15 Oct 2013, 07:39

Now the posts make more sense.

Midlana1
Site Admin
Posts: 2756
Joined: 19 Dec 2008, 16:44
Anti-spam question: 4
Are you a spammer: No
Location: Southern California

Re: Willow Springs, Oct 5-6 2013

Postby Midlana1 » 15 Oct 2013, 10:01

If you aren't following the website, yeah, some of the posts here will leave you scratching your head.


Return to “Trackdays/Autocross”

Who is online

Users browsing this forum: No registered users and 1 guest